WAP Install Form


Prior to the Sicon WAP installation, please ensure the following prerequisites are fulfilled. N.B: if Sage 200 Server is installed and WAP will be installed on that server, most of these will already be enabled.

Important Note: An Active Directory service account needs to be created specifically for WAP. This account may need to be created by the relevant IT responsibility.

Server

  • Windows Server 2008 R2 or above is now the minimum level of operating system; 6GB RAM or greater recommended (Combined for the WAP website and WAP service only, Additional RAM will be required for the OS and other applications), 2.0 Ghz Dual Core or Greater recommended. Web Server and Application Server Roles are installed.
  • IIS: All common HTTP features are installed, such as Static Content, ASP.NET, Anonymous Authentication and Windows Authentication if Single Sign on is required.
  • .NET Framework: 4.7.2 or later. This must be installed and the server rebooted before the WAP install can take place.
  • Sage 200 Client: Version 2015 or later
  • SQL Server: the minimum SQL version 2012 with sufficient access rights
  • Documents: Existing local folder where WAP can save documents to, e.g. C:\WAPDocs or E:\WAPDocs
  • If POP Posting is required for Requisitions, Auto Generate Order Return numbers must be turned on in Sage 200
  • If SOP Posting is required for Sales Orders, Auto Generate Order Return numbers must be turned on in Sage 200
  • 3rd Party Integration enabled in Sage 200 (for WAP add-on package)
  • If SOP Posting is required, SOP User permissions should be configured for the Sage User account the WAP service is using.

Clients

Web WAP

Supported browsers:

  • Microsoft Edge
  • Google Chrome
  • Internet Explorer
  • 2GB RAM or greater;
    • Why is this? The order page can take up quite a bit of memory client side, Windows uses 1-2GB, so a system with 2GB RAM will already be using most of the RAM, so we recommend having 1Gb spare. WAP will work without it as memory is paged to disk, but it would not run as quickly as on machines with more RAM
  • 2Ghz processor or greater
  • JavaScript enabled
  • Popups enabled for WAP server address
  • Minimum 1024 x 786 resolution

Web App

  • Wi-Fi connection and/or;
  • A data plan in order to communicate with the WAP service when outside the range of a Wi-Fi network

WAP App – IOS

  • IOS Version 10.0 or later to run the App

WAP App – Android

  • Minimum Android version 5.0 (API Level 21 Lollipop)

WAP App – Windows UWC

  • Requirements to follow (not currently available)